Welcome to the SR20 Community Forum - The Dash.
Register
SR20 forum logo

Thread: Ignition switch/lock question

+ Reply To Thread
Posts: 1-10 of 15
2018-06-30 15:33:35
#1
Ignition switch/lock question
Hey All, my ignition switch crapped out and so I bought a replacement, but I noticed this wire in the original (with the red wires), and I

a: have no idea what it is

b: don't know how to disconnect it (didn't pop out when I pulled on it)

c: doesn't seem to have a receptacle on the new ignition. Can anyone shed some light for me? Thanks!

also, d: can I bypass this wire if need be, or what do I do?

Hopefully these links work, please tell me if they do not.

old ignition: https://drive.google.com/file/d/1r3qI2Fa9Ef4mBtkS39gfc3g4BHfVw9Ni/view?usp=sharing

new ignition: https://drive.google.com/file/d/1mFgOKNSvnE6CZnHpHWWOaSzel7B7ihXF/view?usp=sharing
2018-06-30 16:24:07
#2
Let me get those images embedded for you.

Old ignition:


New ignition:
Last edited by BenFenner on 2018-07-01 at 17-00-48.
2018-06-30 16:27:12
#3
I'm not sure what it is either. It's maybe an ACC position switch or similar. It looks like those supplying the new ignition cylinder expect you to re-use that switch by installing your old one into the new cylinder. It looks like it will fit?
Last edited by BenFenner on 2018-06-30 at 16-33-47.
2018-06-30 19:52:42
#4
Those images didn't work for me. These do.



2018-07-01 12:13:01
#5
And those images don't work for me.

Surprise, Google Drive is shit for image hosting and sharing. Admittedly it's not designed for that.
pubmatic, host those images properly if you really want us to see them without trouble.

Edit: I've linked the Flickr images from below up in my first post. They might work better.
Last edited by BenFenner on 2018-07-01 at 17-01-14.
2018-07-01 16:24:38
#6
Moved them over to flickr, hopefully this will work. Sorry for the problems everyone.

old ignition: https://flic.kr/p/25XP9Ws

new ignition: https://flic.kr/p/28DqrS3
2018-07-02 18:02:41
#7
So after further inspection, the Red wire/White stripe and Red wire/Blue stripe plug into a harness with a Yellow wire/Blue stripe, and a Yellow wire/Red stripe. I'm wondering if maybe this was part of a JDM harness (as the motor was replaced in the car with a JDM motor before I bought it.) Nothing is matching up in my Haynes manual, and I can't figure out wtf this thing is!!! Anyone have any more ideas?
2018-07-02 20:04:38
#8
Okay, I just went through almost every page of the FSM for you, and here's what I found out.

The image of that part in the Steering section shows those wires, so they probably belong there on USDM models.

I found the three plugs that should be connected to the ignition cylinder, which are E51 Ignition Switch, E52 Key Switch, and E53 Key lock solenoid.
I'm pretty sure you're looking at the Key Lock Solenoid.
Last edited by BenFenner on 2018-07-02 at 20-31-45.
2018-07-02 22:49:53
#9
Nice. Thank you! I'll dig down that hole and see what I can suss out!
2018-07-06 17:40:36
#10
So I think the ignition I bought SHOULD have had the connection on the tumbler, but it doesn't. So I guess now, is there any way to bypass it and call it good, or do I need to return the new ignition and get one with the proper connections?
+ Reply To Thread
Quick Reply
Thread Information
There are currently ? users browsing this thread. (? members & ? guests)
StubUserName

Back to top