Welcome to the SR20 Community Forum - The Dash.
Register
SR20 forum logo

Thread: problems install aviner motor in b14

+ Reply To Thread
Posts: 1-7 of 7
2019-09-05 00:30:23
#1
problems install aviner motor in b14
im haveing trouble getting all the mounts lined up and installed.i got a engine support bat but havent used one before any help and info would be muvch appricaited.
2019-09-05 07:14:04
#2
Make sure the mount on the accessory side is correct for your chassis. Use the one that came with your chassis if at all possible.

I typically mount the cross-member to the engine first using those engine mounts and then bolt the cross-member to the chassis. Then I get the accessory side mount done next, then the transmission mount last since it is the most forgiving with the pointy bolt. This order should also help you figure out if any of the other mounts are incorrect for your chassis.

If you're installing the engine from above, you can still drop it down to get the cross-member stuff setup first then raise it up. But I would recommend bringing the engine up from below.
Last edited by BenFenner on 2019-09-05 at 07-16-08.
2019-09-10 00:23:22
#3
thanks for the info.the engine is already in the car and all bolted in when i get to the tansmission mount i couldnt get it close to lining up so i took the support bar and took all the weight off the mounts and unhooked them all and quite there for now.i do have another question what is the little box looking thing in the middle of the cross member because the oil pan seems to be hitting that?can it be taken off or must it stay?.
2019-09-10 19:48:00
#4
Not sure exactly what you're talking about regarding a box-type thing on the crossmember...
2019-09-11 00:50:43
#5
im not sure what it does but its right in the middle and hits the oil pan
2019-09-11 17:31:11
#6
I had a B14. That is a counter-weight to soak-up any weird NVH (noise vibrations, harshness). I removed mine the first time I did engine mounts on my B14 many years ago. You may do the same.

A P10 has a very large one bolted to the lower radiator support so the same reason.

Last edited by Kyle on 2019-09-11 at 17-37-59.
2019-09-11 19:56:05
#7
I'm more familiar with the harmonic damper on the K-member of the B13 chassis. Sorry, I should have known that was what you were talking about. Yah, ditch that thing.
+ Reply To Thread
Quick Reply
Thread Information
There are currently ? users browsing this thread. (? members & ? guests)
StubUserName

Back to top