Welcome to the SR20 Community Forum - The Dash.
Register
SR20 forum logo

Thread: My pulsar gtir sr20ve-t build

+ Reply To Thread
Posts: 21-30 of 74
2015-06-11 21:17:46
#21
So I pinched my waste gate diaphragm changing springs, ordered a xspower 44mm with 14psi spring, got it installed today had to change both flanges, I can't weld. When we find some time, we will go clean up the map and I will share the findings.
2015-06-13 00:49:10
#22
car looking good bro
2015-06-13 19:30:39
#23
2015-06-26 11:07:52
#24
Looks like you are in Barbados. Good work. VVL+ turbo is the best thing since slice bread. @jdmsentra
2015-07-01 13:27:18
#25
yes sir last images were in six roads
2015-07-06 17:36:33
#26
Good to see a fellow countryman doing big things. Show them boys how the VVL works. @jdmsentra.
2015-07-06 17:44:52
#27
Very solid build.

Love the wheels on the car!
2015-07-06 22:01:05
#28
Hi guys so allot went down. So after changing the wastegate I went out testing the car was only making 8psi, I installed the other spring assuming the other spring was the 15psi spring. The car went to 13psi was close enough for me we did a few logs it resulted in this.
[img][URL=http://s1221.photobucket.com/user/jdmsentra/media/db13psi.jpg.html][IMG]http://i1221.photobucket.com/albums/dd470/jdmsentra/db13psi.jpg[/img][/URL][/IMG]
So we went to increase boost, duty cycle on solenoid went right up no change, changed solenoid same result, we went for a boost leak test and found the bov was damged and leaking badly as well as a torn coupling off the turbo. changed the coupling changed the bov went for a pull straight onto boost cut which at the time was 21psi. A few days later we went back to tuning 25psi boost cut applied And out to test. Car felt great at the end of the pull I heard a funny noise limped home, revved the car in the garage with the car in neutral no noise, as I previously mentioned I had a rattling gearbox we assumed it had given up, jacked up the car out with the old box and tcase In with the new two days later we got it on the ground started the car let it idle whilst I was adding coolant and letting the fan cycle, engine sounded nice rolled the car out the garage rattle from drive line area and vibration in the clutch pedal. Car felt normal aside from the rattle consulted my guys we came to the conclusion the pressure plate got damaged we didn't inspect it sadly because we were rushing to prepare for 1/8th mile racing the weekend which would have been yesterday. Drained the oil in the motor fresh engine oil and off tuning again we also change the wastegate spring back to the original one whilst the engine was out. went testing car was on 15psi spring pressure upped boost slowly to 20psi on the last pull the rattle got LOUD.

[img][URL=http://s1221.photobucket.com/user/jdmsentra/media/db20psi_1.jpg.html][IMG]http://i1221.photobucket.com/albums/dd470/jdmsentra/db20psi_1.jpg[/img][/URL][/IMG]
We parked the car because we were racing one way or the other

Day of the event we went for a practice run got lock out no gears, we went back to the pit, adjusted the clutch pedal went for another hit, and boom smoke out the bonnet block got a port job. So we had catastrophic failure. will pull down this week, hopefully the head survived. Will post pictures
Last edited by jdmsentra on 2015-07-08 at 17-02-40.
2015-07-06 22:04:51
#29
Thanx SE-Rican and Kevwal
2015-07-06 22:34:05
#30
anybody with a 4wd block for sale please pm me.
+ Reply To Thread
Quick Reply
Thread Information
There are currently ? users browsing this thread. (? members & ? guests)
StubUserName

Back to top