Welcome to the SR20 Community Forum - The Dash.
Results 1 to 17 of 17
  1. #1
    Member
    User Info
    Join Date: Apr 2010
    Location: Tomball, TX
    Posts: 51
    Feedback Score: 0

    Default check engine light problems

    I have been trying to clear the check for the down stream O2 sensor but the light continues to come back. I have changed the sensor, cat back, and ECU. Dont know what else to do. 1999 SE-l
    SE-L 99
    Crx Si 90 D16

  2. #2
    SR20 Hoarder
    User Info
    Join Date: Dec 2007
    Location: Vermilion, Ohio
    Posts: 5,917
    Feedback Score: 52 (100%)

    Default

    Changed the front one yet? Usually the front will set the rear off.
    93 Se-R The New Project 01 Sentra SE The DD
    96 G20 Sold*99 Sentra SE-L Sold 13.0227@113mph
    *94 Sentra Se-R Sold SOLD*95 200sx Se-R Sold
    *I'm a VRS Dealer, PM me if you need an exhaust!* <-- Prices

  3. #3
    Member
    User Info
    Join Date: Apr 2010
    Location: Tomball, TX
    Posts: 51
    Feedback Score: 0

    Default

    yeah, I changed both.
    SE-L 99
    Crx Si 90 D16

  4. #4
    SR20 Hoarder
    User Info
    Join Date: Dec 2007
    Location: Vermilion, Ohio
    Posts: 5,917
    Feedback Score: 52 (100%)

    Default

    Any other Codes or just that one?
    93 Se-R The New Project 01 Sentra SE The DD
    96 G20 Sold*99 Sentra SE-L Sold 13.0227@113mph
    *94 Sentra Se-R Sold SOLD*95 200sx Se-R Sold
    *I'm a VRS Dealer, PM me if you need an exhaust!* <-- Prices

  5. #5
    Member
    User Info
    Join Date: Apr 2010
    Location: Tomball, TX
    Posts: 51
    Feedback Score: 0

    Default

    no, thats all.
    SE-L 99
    Crx Si 90 D16

  6. #6
    SR20 Hoarder
    User Info
    Join Date: Dec 2007
    Location: Vermilion, Ohio
    Posts: 5,917
    Feedback Score: 52 (100%)

    Default

    Well usually the Rear 02 is worthless as it just makes sure the front one is working. That's why I asked if the front one was good because they usually go hand in hand. Something else must be going on maybe the actually wiring to the 02 sensor. Maybe try to check the voltage to see if it's seeing what it needs to?
    93 Se-R The New Project 01 Sentra SE The DD
    96 G20 Sold*99 Sentra SE-L Sold 13.0227@113mph
    *94 Sentra Se-R Sold SOLD*95 200sx Se-R Sold
    *I'm a VRS Dealer, PM me if you need an exhaust!* <-- Prices

  7. #7
    Member
    User Info
    Join Date: Apr 2010
    Location: Tomball, TX
    Posts: 51
    Feedback Score: 0

    Default

    Ill check the voltage. I have sadered the wires
    SE-L 99
    Crx Si 90 D16

  8. #8
    SR20 Hoarder
    User Info
    Join Date: Dec 2007
    Location: Vermilion, Ohio
    Posts: 5,917
    Feedback Score: 52 (100%)

    Default

    That could be the issues, I would cut the solder out and just crimp and heat shrink it.
    93 Se-R The New Project 01 Sentra SE The DD
    96 G20 Sold*99 Sentra SE-L Sold 13.0227@113mph
    *94 Sentra Se-R Sold SOLD*95 200sx Se-R Sold
    *I'm a VRS Dealer, PM me if you need an exhaust!* <-- Prices

  9. #9
    Member
    User Info
    Join Date: Apr 2010
    Location: Tomball, TX
    Posts: 51
    Feedback Score: 0

    Default

    I'll try that tomorrow, I just talked to my brother and he told me to check the voltage with the car running. The connector should read 12v on one wire and 5v on another. I'm going to cut the solder and crimp it. Thanks for the help, I'll let you know how it goes.
    SE-L 99
    Crx Si 90 D16

  10. #10
    Member
    User Info
    Join Date: Feb 2012
    Posts: 48
    Feedback Score: 0

    Default

    Did you get a universal sensor with 4 wires? You have your 2 heater and 1 signal and a designated ground wire. I just replaced my front OEM sensor with a Bosch universal and works great. I'm sure the back one is the same way?
    Joe
    99 SE-L slowly being modded

  11. #11
    Member
    User Info
    Join Date: Apr 2010
    Location: Tomball, TX
    Posts: 51
    Feedback Score: 0

    Default

    It is a universal sensor, a Bosch to be exact. I have crimped the wires and cheked the voltage. 12v, 5v. I dont know what else to do to get the code cleared and fixed for inspection. I dont know if it can be bad carb build up or what else it can be. I look up the live data and Os1b1 shows volts, Os2b2 shows 0, no voltage or activity. how can i find out what it can be? front O2 sensor changed new cat. I might get the old cat on and old fused sensor off but I dont want to continue spending money.
    SE-L 99
    Crx Si 90 D16

  12. #12
    SR20 Hoarder
    User Info
    Join Date: Dec 2007
    Location: Vermilion, Ohio
    Posts: 5,917
    Feedback Score: 52 (100%)

    Default

    Well if the wire is feeding voltage 2 things. Dead sensor or you wired it incorrectly.
    93 Se-R The New Project 01 Sentra SE The DD
    96 G20 Sold*99 Sentra SE-L Sold 13.0227@113mph
    *94 Sentra Se-R Sold SOLD*95 200sx Se-R Sold
    *I'm a VRS Dealer, PM me if you need an exhaust!* <-- Prices

  13. #13
    Oh well....
    User Info
    Join Date: Jan 2012
    Location: Philly Burbs
    Posts: 6,574
    Feedback Score: 46 (98%)

    Default

    I'm having the same problem, replaced both front and rear 02 sensors in my 97 SE-R but still getting codes of 0707 and 0901, front & rear sensors. Reset the ECU, tried the stock ECU, tried the JWT ECU, keeps throwing codes. I have all but given up and taking it somewhere later to be figured out.
    Last edited by Storm88000; 06-27-12 at 05:01 PM.
    Jordan
    '98 SE-R, '00 G20t VVL, '12 Versa Hatchback, '17 Juke Nismo autotragic
    Music - - My SR20 website

  14. #14
    Member
    User Info
    Join Date: Feb 2012
    Posts: 48
    Feedback Score: 0

    Default

    Clogged cat?
    Joe
    99 SE-L slowly being modded

  15. #15
    N1 powa
    User Info
    Join Date: Dec 2007
    Location: Kingwood, Tx
    Posts: 2,384
    Feedback Score: 8 (100%)

    Default

    Cat is brand new. Need to check the wiring from the ecu to the o2 sensor . 2 bad ecus don't make send
    '94 Suzuki Swift GT A.K.A The Little Engine That Can - 40 MPG Never Felt So Good
    '96 200 SX SE-R VZR N1 Version 1 - Neo AFC, Calum Basic, 9lbs flywheel, stillen cam gears, ssac header, 3" exhaust, Innovate wide band, Tein Flex, G spec pulleys & Apex N1
    Them -Is that a 2.0. ME - Naw its a 1.6 Them - :eek:
    PS3 Tag :Miami4ThatAss/BURN1SLOW
    Ill Always Be A Miami Boy!!!
    God Bless SEAL TEAM 6

  16. #16
    N1 powa
    User Info
    Join Date: Dec 2007
    Location: Kingwood, Tx
    Posts: 2,384
    Feedback Score: 8 (100%)

    Default

    There's signal to the ecu and ground . Even connected the sensor to a external ground still no signals. Kinda lost now everything seems to be there. I've tried jwt ecu and a 99 g20 ecu

  17. #17
    Oh well....
    User Info
    Join Date: Jan 2012
    Location: Philly Burbs
    Posts: 6,574
    Feedback Score: 46 (98%)

    Default

    I hate 02 sensors.... I just thought I'd share that
    Jordan
    '98 SE-R, '00 G20t VVL, '12 Versa Hatchback, '17 Juke Nismo autotragic
    Music - - My SR20 website

 

 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Back to top