Welcome to the SR20 Community Forum - The Dash.
Results 1 to 6 of 6
  1. #1
    super jdm
    User Info
    Join Date: Dec 2007
    Location: White Center, WA
    Posts: 61
    Feedback Score: 2 (100%)

    Default Transmission issue

    Has anyone seen or know how to prevent this? This is the second time it's happened to me. The clutch and pressure plate that I am using is the Exedy OE replacement.
    IMG_0871.jpg]IMG_0871.jpg Photo by satadysok | Photobucket
    Last edited by b14lucino; 03-23-17 at 11:08 PM.

  2. #2
    SR20VE-T Boost Junky!
    User Info
    Join Date: Sep 2008
    Location: Washougal, Washington
    Posts: 9,834
    Feedback Score: 17 (100%)

    Default

    You get that trans in yet?

  3. #3
    Exhaustipation!
    User Info
    Join Date: Nov 2009
    Location: TEXAS!
    Posts: 3,349
    Feedback Score: 6 (100%)

    Default

    Prevent what? What are you trying to show us in the pic? Sry, tiny phone pic on my end.

  4. #4
    1994.5 LE-R
    User Info
    Join Date: Aug 2011
    Location: Auburn, AL
    Posts: 580
    Feedback Score: 0

    Default

    Clutch cable ARM is broken at the pivot where it is welded.

  5. #5
    SR20VE-T Boost Junky!
    User Info
    Join Date: Sep 2008
    Location: Washougal, Washington
    Posts: 9,834
    Feedback Score: 17 (100%)

    Default

    He has a good sr16ve box to use now

  6. #6
    daily sr20! yes!
    User Info
    Join Date: Dec 2007
    Location: Outside Philly
    Posts: 1,584
    Feedback Score: 15 (100%)

    Default

    I'm pretty sure others have welded on reinforcement plates on the top. sounds like you got it figured out though
    don't lift, keep in it

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Back to top