Welcome to the SR20 Community Forum - The Dash.
Results 1 to 10 of 10
  1. #1
    Member
    User Info
    Join Date: Jul 2010
    Location: Hayward, CA
    Posts: 213
    Feedback Score: 0

    Default Trying to figure out how to raise the ignition timing with S4 cams

    I need help figuring out a couple things here...

    1) I need to Raise Idle speed so it doesn't Periodically die at idle or low speeds. (This happens often in parking lots when clutching a lot)
    2) I need to figure out how to raise set my timing to 17 degrees and be SURE its at 17 degrees.


    Before the cams, i had idle set at 750, TPS/IACV UNPLUGGED. (yes i have the car that requires the IACV to be unplugged to set base idle, took me forever to figure this out too) It idles around 850 with them plugged in. i need to raise the idle so that when the sensors ARE plugged in, it idles around 1000, How do i do this?

    Then how to i set the base timing? what RPM can i set base timing in? too low= lopey as hell and i cant figure out where the timing is when the marks are jumping all over the place...

    Ive searched for this.. people just do it, and report they have done it, but theres still no "HOW-TO: Adjust proper idle and timing with S4 cams" thread. BTW running stock ECU for now and i have no conzult or anything like that...
    1991 NX2000 DD/project

  2. #2
    SR Racer
    User Info
    Join Date: Dec 2007
    Location: Portland OR.
    Posts: 269
    Feedback Score: 2 (100%)

    Default

    Base idle and Timing has to be done with the TPS unplugged . engine warmed up,.... You should not have the IACV unplugged ( although it doesnt matter since the IACV should not do anything with the TPS unplugged ... ) ... Timing is checked when Base Idle is at spec ... Somewhere around 850 or so ... ... Yea, the S4's will bounce around a little , but if everything is how it should be , you should be able to set timing at 850 easy ... I just rechecked my Timing with my S4's and had no issue ...

    Once your timing is set , then plug in the TPS , run it for a while and then you can set the idle wherever you want it to be with the idle adjustment screw ...
    Last edited by SHAWNATGERBROCK; 08-02-11 at 05:30 PM.
    Shawn
    Auto Shop Northwest
    '98 Sentra SE ..'09 Titan SE CC LB...'93 G20 12.06 @ 119
    My Site ..

  3. #3
    Member
    User Info
    Join Date: Jul 2010
    Location: Hayward, CA
    Posts: 213
    Feedback Score: 0

    Default

    Quote Originally Posted by SHAWNATGERBROCK View Post
    Base idle and Timing has to be done with the TPS unplugged . engine warmed up,.... You should not have the IACV unplugged

    In most cases... yes. ur are right. but not in this case..

    My car is one of the weird ones where it needs the IACV unplugged as well or else it idles at 1500 with JUST the TPS unplugged



    ^^^^^^^^^^^ This was not important to my post tho.. it was just background story. i just need help setting idle higher so i can accurately set the freakin timing
    1991 NX2000 DD/project

  4. #4
    Member
    User Info
    Join Date: Jul 2010
    Location: Hayward, CA
    Posts: 213
    Feedback Score: 0

    Default

    i read in another post if the transmission neutral switch isnt plugged in, u cant get into timing mode. im running a p11 swap and i dont have the neutral switch... is this preventing me from getting into timing mode?
    1991 NX2000 DD/project

  5. #5
    Member
    User Info
    Join Date: Mar 2011
    Posts: 63
    Feedback Score: 0

    Default

    Dude, you should get something to get your AFR more rich, a fiend of mine had that problem, and he got a SAFC, he added more fuel in low RPMS and problem solved, idles normaly and you barely hear the cams...
    Does a SR20DE can rev to 10 000 RPMS... yes then it will not rev any more... Broken...
    VE madness is on the way!

  6. #6
    Member
    User Info
    Join Date: Jul 2010
    Location: Hayward, CA
    Posts: 213
    Feedback Score: 0

    Default

    How do u reset the ECU on these?? is there a specific way or do u just take the neg wire off the battery for a while? i wanna reset the self learning, does that happen when the ecu resets?
    1991 NX2000 DD/project

  7. #7
    Member
    User Info
    Join Date: Jul 2010
    Location: Hayward, CA
    Posts: 213
    Feedback Score: 0

    Default

    Quote Originally Posted by CR Guy View Post
    Dude, you should get something to get your AFR more rich, a fiend of mine had that problem, and he got a SAFC, he added more fuel in low RPMS and problem solved, idles normaly and you barely hear the cams...
    i bought an AEM series2 standalone, should help.
    1991 NX2000 DD/project

  8. #8
    The People's Mod
    User Info
    Join Date: Dec 2007
    Location: Columbia, SC
    Posts: 17,925
    Feedback Score: 16 (100%)

    Default

    Had I known a multi-thousand dollar ECU upgrade was an option, I would have recommended it as a solution yesterday.

  9. #9
    Member
    User Info
    Join Date: Jul 2010
    Location: Hayward, CA
    Posts: 213
    Feedback Score: 0

    Default

    Quote Originally Posted by BenFenner View Post
    Had I known a multi-thousand dollar ECU upgrade was an option, I would have recommended it as a solution yesterday.
    lol.. ;D
    1991 NX2000 DD/project

  10. #10
    Member
    User Info
    Join Date: Feb 2011
    Location: England
    Posts: 78
    Feedback Score: 2 (100%)

    Default

    Surely if you just wind out the idle adjust screw with the IACV unplugged, you can bring the idle up?

 

 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Back to top